Skip to content

SoFy Documentation
v0.13.0

PDF

Supported Kubernetes Environments

There are many options for utilizing your own Kubernetes environment:

  • Open source Kubernetes can be used for a self-managed environment
  • Most public cloud vendors provide supported Kubernetes installations, for example Google Kubernetes Engine and Amazon Elastic Kubernetes Service
  • Some private cloud platforms allow Kubernetes to run in your data center or public cloud account

HCL SoFy is designed to allow solutions to run in any Kubernetes environment. Solution dependencies relate to core Kubernetes only, with no use of vendor-specific services. With a growing number of Kubernetes vendors, however, solutions are tested on specific sets as listed below. If you run SoFy Solutions in a different environment, we do our best to address any issues but may need to work with you directly to debug problems that appear to be specific to your environment.

Please note that individual products and services in the SoFy Catalog may document their own support policies for different Kubernetes versions and providers.

Tested Kubernetes Environments

  • Google Kubernetes Engine
  • Amazon Elastic Kubernetes Service
  • Azure Kubernetes Service
  • Red Hat OpenShift Container Platform
    • OpenShift security policies mean that most Helm charts will not work out of the box. Please check the documentation for the individual catalog items to see if instructions are provided for installation on OpenShift.

Supported Kubernetes Versions

The Kubernetes project couples frequent releases with a strict compatibility policy, to allow rapid innovation of the platform but to minimize impacts of those updates to existing applications. Most update issues can be avoided by using only generally available (stable) APIs, but even those may sometimes be deprecated and eventually removed. Solutions built on the current version of SoFy are supported when run on the following tested Kubernetes versions:

  • 1.20
  • 1.21
  • 1.22

Cluster Requirements and Limitations

  • Cert-Manager must be installed in the cluster; version 0.15.1 or later
  • Each solution must be installed in a separate namespace
  • The Helm 3 client must be used to install solutions; supported version: 3.3.0 or later
  • When the cluster is k8s v1.22 or newer, the minimum version of Cert-Manager is 1.8.2 and the minimum version of Helm is 3.7.0